Uploaded image for project: 'CDAP'
  1. CDAP
  2. CDAP-10619

Importing a legacy pipeline into CDAP should be more user friendly

    Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Critical
    • Resolution: Duplicate
    • Affects Version/s: 4.1.0
    • Fix Version/s: 4.3.0
    • Component/s: Pipelines, UI
    • Labels:
    • Release Notes:
      UI: Add upgrade step when importing pipeline
    • Rank:
      1|hzzwt3:

      Description

      Upgrading legacy pipelines to a new version of CDAP has always been a pain because of all the versions, artifacts, etc.

      When a user imports an old pipeline with legacy versions, CDAP should ask if they'd like to upgrade the plugins instead of just failing.

      Also, if the plugin is available in a different scope, CDAP should ask the user if they'd like to use the plugin from a different scope.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                edwin Edwin Elia
                Reporter:
                russellsavage Russ Savage
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: