Uploaded image for project: 'CDAP'
  1. CDAP
  2. CDAP-1174

init script functions should be named more specifically (namespace)

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.3.0
    • Component/s: CDAP
    • Labels:
      None
    • Release Notes:
      Prefix start script functions with cdap to prevent namespace collisions
    • Rank:
      1|hzyl4n:

      Description

      Our init script common functions should be named with cdap-specific names, essentially namespacing them. As we integrate cdap with other systems, this can be an issue. I've already hit an issue where CDAP's "set_hive_classpath" function conflicted with another "set_hive_classpath" in the framework I was launching it from.

        Attachments

          Activity

            People

            • Assignee:
              chris Chris Gianelloni
              Reporter:
              derek Derek Wood
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: