Uploaded image for project: 'CDAP'
  1. CDAP
  2. CDAP-11981

Improve parsing for HDP version in the Ambari service

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 4.2.0, 4.1.1
    • Fix Version/s: 4.3.0
    • Component/s: Ambari Service
    • Labels:
      None
    • Rank:
      1|i0048f:

      Description

      In the Amabri service we determine the HDP version by parsing a shell call(`hadoop version`). If this call has an error or warning CDAP will fail to install. We need to find a better way to parse the version.

        Attachments

          Activity

            People

            • Assignee:
              mattwuenschel Matt Wuenschel
              Reporter:
              mattwuenschel Matt Wuenschel
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: