Uploaded image for project: 'CDAP'
  1. CDAP
  2. CDAP-12273

packer cookbook install needs a dependency resolver

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Distribution
    • Labels:
      None
    • Rank:
      1|i005yn:

      Description

      knife cookbook site install does not respect dependency versions. This caused an issue when sysctl was released, and broke all distribution formats using https://github.com/caskdata/cdap/blob/develop/cdap-distributions/src/packer/scripts/cookbook-setup.sh#L27.

      We should be able to resolve issues like this by constraining cookbook metadata. If packer distributions used an actual cookbook resolver like berkshelf, we could do so.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                derek Derek Wood
                Reporter:
                derek Derek Wood
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: