Uploaded image for project: 'CDAP'
  1. CDAP
  2. CDAP-12283

Authorization policy should not include version for entities

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.3.0
    • Component/s: Security
    • Labels:
    • Release Notes:
      Removed version for artifacts for authorization policy to be consistent with applications. From 4.3 onwards CDAP does not support policies on artifact/application version.
    • Rank:
      1|i0060n:

      Description

      Including versions in authorization policy for entities like artifacts and applications can make the authorization policy complicated.

      For example, alice - an admin on application feed-generator-1.0.0 will not be able to upgrade the application to feed-generator-1.0.1

      Since we don't have a usecase currently to authorize on entity versions, I propose that we remove version from authorization policy for entities until we have a good usecase.

        Attachments

          Activity

            People

            • Assignee:
              rsinha Rohit Sinha
              Reporter:
              poorna Poorna Chandra
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: