Uploaded image for project: 'CDAP'
  1. CDAP
  2. CDAP-14459

Jumping to a dataset that does not exist has weird message

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Pipelines, UI
    • Labels:
      None
    • Rank:
      1|i00ien:

      Description

      To reproduce:

      1. Deploy a pipeline that uses a source or sink that has a reference name, like the GCS sink. Make sure to give it a unique name

      2. Click on the sink and then click on the 'View Details' button.

      3. You will be sent to a page that looks like the attached image.

      This behavior happens because the dataset is only created when the pipeline runs, so it doesn't exist yet. If the dataset doesn't exist, the UI should display some nicer error, as we know what went wrong.

      We can also try to avoid this situation by creating the dataset at deploy time in the backend so we don't get into this situation to begin with. Though even if we do that, the UI should still handle this error better.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                priyanka Priyanka Nambiar
                Reporter:
                ashau Albert Shau
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: