Uploaded image for project: 'CDAP'
  1. CDAP
  2. CDAP-3010

Bower Dependency Error

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.1.0, 2.8.2, 3.0.3
    • Component/s: UI
    • Labels:
      None
    • Rank:
      1|hzyw1r:

      Description

      cdap-ui uses DagreD3 which internally uses lodash as a utility library.

      The issue occurred because we were using 'closely-matching' version (dagred3: ~0.4.0) in our bower.json.

      When dagred3 made a minor upgrade from 0.4.9 to 0.4.10 it internally upgraded lodash from 2.4 to 3.2 (major upgrade).

      Since lodash moved its compiled files from /dist/lodash.js to /lodash.js in its bower repository it directly affected us (since we pull in the dependencies manually for dagred3).

        Attachments

          Activity

            People

            • Assignee:
              ajai Ajai Narayan
              Reporter:
              ajai Ajai Narayan
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: