Uploaded image for project: 'CDAP'
  1. CDAP
  2. CDAP-3175

AbstractFlowlet constructors should not be deprecated

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1.0
    • Fix Version/s: 3.1.0
    • Component/s: API
    • Labels:
      None
    • Rank:
      1|hzywzb:

      Description

      AbstractFlowlet() and AbstractFlowlet(String name) are annotated as deprecated, That means anybody who extends AbstractFlowlet (the only way to define a flowlet) gets a deprecation warning.

      Warning:(27, 18) java: AbstractFlowlet() in co.cask.cdap.api.flow.flowlet.AbstractFlowlet has been deprecated
      

      These constructors should not be deprecated

        Attachments

          Activity

            People

            • Assignee:
              gokul Gokul Gunasekaran
              Reporter:
              andreas Andreas Neumann
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: