Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.2.0
    • Component/s: Applications
    • Labels:
      None
    • Release Notes:
      Changed plugin types from 'source' to 'batchsource' and 'realtimesource', and from 'sink' to 'batchsink' and 'realtimesink' to reflect that the plugins implement different interfaces.
    • Rank:
      1|hzyz0n:

      Description

      We want to change "source" types to "BatchSource" and "RealtimeSource". We also want to change "sink" types to "BatchSink" and "RealtimeSink". Since those plugins are used differently, we want their types to be different.

      This will also let us transition into a world where a plugin artifact does not have to declare which artifacts it extends, and applications can just use those plugins if they have the right dependencies. In that scenario, type and name will have to uniquely identify the plugin.

        Attachments

          Activity

            People

            • Assignee:
              ashau Albert Shau
              Reporter:
              ashau Albert Shau
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: