Uploaded image for project: 'CDAP'
  1. CDAP
  2. CDAP-4141

standalone startup script fails on newer node.js versions

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.3.0
    • Component/s: None
    • Labels:
      None
    • Release Notes:
      Fixed node.js version checking for the cdap.sh script in the cdap sdk.
    • Rank:
      1|hzz2if:

      Description

      ashau@Alberts-MacBook-Pro-2:~/cdap-sdk-3.3.0-SNAPSHOT$ bin/cdap.sh start
      
      ERROR: Node.js version is not supported
      The minimum version supported is v0.10.0.
      
      ashau@Alberts-MacBook-Pro-2:~/cdap-sdk-3.3.0-SNAPSHOT$ node -v
      v4.2.1
      

      cdap.sh checks your node version to see that it's > 0.10.0. But the way it does that is by comparing the second number to 10. So in my case, 2 < 10, so 4.2.1 < 0.10.0

        Attachments

          Activity

            People

            • Assignee:
              nitin Nitin Motgi
              Reporter:
              ashau Albert Shau
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: