Uploaded image for project: 'CDAP'
  1. CDAP
  2. CDAP-6939

UI breaks on older version of chrome (<44.x.x.x)

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.5.0
    • Component/s: UI
    • Labels:
      None
    • Release Notes:
      Fixes support for chrome < 44 version. UI is using Ecmascript 2015 that older browsers doesn't implement. Added proper transpilation to support older browsers in VMs.
    • Rank:
      1|hzzja7:

      Description

      The older version of chrome/chromium (<44) renders UI in a broken state. This is because we use Object.assign JS API which is not available in older browsers. We need to add a polyfill for this API.

        Attachments

          Activity

            People

            • Assignee:
              ajai Ajai Narayan
              Reporter:
              ajai Ajai Narayan
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: