Uploaded image for project: 'CDAP'
  1. CDAP
  2. CDAP-7343

Non-versioned REST APIs should only operate on non-versioned apps

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.6.0
    • Component/s: App Fabric
    • Labels:
      None
    • Release Notes:
      All non-versioned endpoints are now directed to applications with a default version. Added test cases with a mixed usage of the new versioned endpoints and the corresponding non-versioned endpoints.
    • Rank:
      1|hzzmcn:

      Description

      Regarding the behavior of non-versioned REST APIs - I think non-versined REST APIs like start, stop, delete, etc. should only operate on the non-versioned app. If there is no non-versioned app present then they should return 404 like they do today. If we allow non-versioned REST APIs to operate on versioned app (if there is only one version present) then it leads to confusion.

        Attachments

          Activity

            People

            • Assignee:
              mao Chengfeng Mao
              Reporter:
              poorna Poorna Chandra
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: