Uploaded image for project: 'CDAP'
  1. CDAP
  2. CDAP-7652

CDAP master should not startup if it detects unknown HBase version

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0.0
    • Component/s: App Fabric
    • Labels:
      None
    • Release Notes:
      Startup checks now validate the HBase version and error if the HBase version is not supported.
    • Rank:
      1|hzzoqv:

      Description

      When CDAP is started with unsupported version of HBase then appropriate error should be logged and the CDAP master process should fail to startup.

      Currently the master process doesn't die and the following errors are seen in master log

      2016-11-10 22:36:06,230 INFO co.cask.cdap.master.startup.MasterStartupTool: Hadoop subsystem versions:
      2016-11-10 22:36:06,239 INFO co.cask.cdap.master.startup.MasterStartupTool:   Hadoop version: 2.6.0-cdh5.9.0
      2016-11-10 22:36:06,259 INFO co.cask.cdap.master.startup.MasterStartupTool:   HBase version: 1.2.0-cdh5.9.0
      2016-11-10 22:36:06,262 INFO co.cask.cdap.master.startup.MasterStartupTool:   ZooKeeper version: 3.4.5.1405704
      2016-11-10 22:36:06,264 INFO co.cask.cdap.master.startup.MasterStartupTool:   Kafka version: 0.8.2.2
      2016-11-10 22:36:06,398 INFO co.cask.cdap.master.startup.MasterStartupTool:   Hive version: 1.1.0-cdh5.9.0
      2016-11-10 22:36:06,401 INFO co.cask.cdap.master.startup.MasterStartupTool: CDAP version: 3.6.0-1475694414377
      

        Attachments

          Activity

            People

            • Assignee:
              ashau Albert Shau
              Reporter:
              sree Sreevatsan Raman
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: