Uploaded image for project: 'CDAP'
  1. CDAP
  2. CDAP-8430

"No Entities Found" message in the Entity View List

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.2.0, 4.1.1
    • Component/s: UI
    • Labels:
    • Sprint:
      CDAP UI 02/27 (4.2), CDAP UI 03/13
    • Release Notes:
      Users can now see a contextual message with appropriate call(s) to action when no entities are found on the Overview page.
    • Rank:
      1|hzy30v:

      Description

      As a user, I want to have a clear feedback that reflects the status of any given search and/or filter action.

      If a search query and/or a filter selection doesn't bring any results, a message should be displayed, together with a purposeful call to action.

      • No Matching Search Results message:
        No results found for "<query>.
        You can try to:
        Clear your search –> Values are reset to no search, no filter, Sort by Newest
        Add new entities –> Resource Center modal is displayed
      • No Matching Filter Results message
        No results found for your selection.
        You can try to:
        Clear your filters –> Values are reset to no search, no filter, Sort by Newest
        Add new entities –> Resource Center modal is displayed
      • No Entities in the namespace
        No entities found in this namespace
        Add new entities –> Resource Center modal is displayed

      Follow attached screen shot for visuals.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tbach Tony Bach
                Reporter:
                lea Lea
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: