Uploaded image for project: 'CDAP'
  1. CDAP
  2. CDAP-9185

Pipeline upgrade tool does not upgrade 4.0.x pipelines

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.1.0, 4.0.1
    • Fix Version/s: 4.1.1, 4.0.2
    • Component/s: None
    • Labels:
      None
    • Release Notes:
      Fixed an issue with the pipeline upgrade tool that caused it to skip CDAP 4.0.x pipelines.
    • Rank:
      1|hzzyr3:

      Description

      The pipeline upgrade tool decides whether to upgrade a pipeline or not by checking the major version is 3 and the minor version is 2 or more. This means it will not upgrade any pipelines from 4.0.x.

        Attachments

          Activity

            People

            • Assignee:
              ashau Albert Shau
              Reporter:
              ashau Albert Shau
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: