Uploaded image for project: 'CDAP'
  1. CDAP
  2. CDAP-9436

Allow latest HBase or Hive version to be used when HBase or Hive version is unknown

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.1.1
    • Fix Version/s: 4.2.0, 4.1.2
    • Component/s: App Fabric
    • Labels:
      None
    • Release Notes:
      Hide
      Add property "hbase.version.resolution.strategy" and "hive.version.resolution.strategy" to determine how to behave when the HBase/Hive version on a cluster is an unsupported value. The default value of both properties is "auto.strict", which will requires a supported version for HBase/Hive. Set to "auto.latest" to use the latest HBase/Hive version available on the cluster with an unsupported HBase/Hive version.
      Show
      Add property "hbase.version.resolution.strategy" and "hive.version.resolution.strategy" to determine how to behave when the HBase/Hive version on a cluster is an unsupported value. The default value of both properties is "auto.strict", which will requires a supported version for HBase/Hive. Set to "auto.latest" to use the latest HBase/Hive version available on the cluster with an unsupported HBase/Hive version.
    • Rank:
      1|i0006n:

      Description

      Currently, if HBase or Hive version is unknown, exception will be thrown. However, if there is a newer version and CDAP has not supported it yet, the user may just want to use the latest HBase or Hive version available in CDAP without throwing exception.

        Attachments

          Activity

            People

            • Assignee:
              mao Chengfeng Mao
              Reporter:
              mao Chengfeng Mao
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: