Uploaded image for project: 'Cookbooks'
  1. Cookbooks
  2. COOK-126

issues with hadoop cookbook on ubuntu 16

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: hadoop
    • Labels:
      None
    • Rank:
      1|i005nb:

      Description

      The _compression_libs.rb recipe fails on ubuntu 16 because they changed the name of the libsnappy1 package to libsnappy1v5.

      The following will solve this issue:

      --- a/recipes/_compression_libs.rb
      +++ b/recipes/_compression_libs.rb
      @@ -24,7 +24,11 @@ pkgs = []
       # Everybody gets snappy
       case node['platform_family']
       when 'debian'
      -  pkgs += ['libsnappy1', 'libsnappy-dev']
      +  if node['platform_version'] == '16.04'
      +      pkgs += ['libsnappy1v5', 'libsnappy-dev']
      +  else
      +      pkgs += ['libsnappy1', 'libsnappy-dev']
      +  end
       when 'rhel', 'amazon'
         pkgs += ['snappy', 'snappy-devel']
       end
      

        Attachments

          Activity

            People

            • Assignee:
              derek Derek Wood
              Reporter:
              gregwohletz Greg Wohletz
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: