Cookbooks
  1. Cookbooks
  2. COOK-24

hortonworks HDP 2.1.7 (and others?) APT repo is not signed

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Component/s: hadoop
    • Labels:
      None
    • Rank:
      1|hzynpj:

      Description

      Despite what hortonworks docs say, the APT repo for HDP 2.1.7 is not signed. Attempting to install via the hadoop cookbook, it fails since packages can not be authenticated. We may need to turn off gpgcheck.

      root@205:/etc/apt/sources.list.d# apt-get -q -y install hadoop-client=2.4.0.2.1.7.0-784
      Reading package lists...
      Building dependency tree...
      Reading state information...
      The following extra packages will be installed:
        bigtop-jsvc hadoop hadoop-hdfs hadoop-mapreduce hadoop-yarn zookeeper
      The following NEW packages will be installed:
        bigtop-jsvc hadoop hadoop-client hadoop-hdfs hadoop-mapreduce hadoop-yarn zookeeper
      0 upgraded, 7 newly installed, 0 to remove and 34 not upgraded.
      Need to get 86.7 MB of archives.
      After this operation, 99.9 MB of additional disk space will be used.
      WARNING: The following packages cannot be authenticated!
        bigtop-jsvc zookeeper hadoop hadoop-hdfs hadoop-yarn hadoop-mapreduce hadoop-client
      E: There are problems and -y was used without --force-yes
      

        Activity

        Hide
        Chris Gianelloni added a comment -

        Fixed in 1.10.1

        Show
        Chris Gianelloni added a comment - Fixed in 1.10.1

          People

          • Assignee:
            Chris Gianelloni
            Reporter:
            Derek Wood
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: