Uploaded image for project: 'Coopr'
  1. Coopr
  2. COOPR-612

maven-shade-plugin corrupt coopr-cli jar

    XMLWordPrintableJSON

    Details

    • Sprint:
      Tracking Sprint 4
    • Rank:
      1|hzyhmn:

      Description

      When you try to run coopr-cli jar java.lang.SecurityException is thrown,
      because one of the dependencies is a signed jar. As the shade plugin is repacking this jar, it gets invalid.
      To solve the problem, we have to unsign the dependency jars while repacking them. This can be done by simply not repacking the files that make the jar signed, using a filter.

        Attachments

          Activity

            People

            • Assignee:
              artemmakogon Artem Makogon
              Reporter:
              artemmakogon Artem Makogon
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: