Uploaded image for project: 'Coopr'
  1. Coopr
  2. COOPR-672

Attribute-driven ability to install/upgrade/remove packages

    XMLWordPrintableJSON

    Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.9.8, Code Name: Centaurus
    • Component/s: plugins
    • Labels:
      None
    • Sprint:
      Coopr 01/19, Coopr 01/26
    • Rank:
      1|hzy82n:

      Description

      On certain providers - Ex: GCE, yum cron packages are installed automatically. This will upgrade packages on a nightly basis.

      This is not a great user experiences for users provisioning cluster. For instance a user could have provisioned CDAP cluster with versionX and deployed apps compiled against them. When we release versionY the cluster will be upgraded automatically to versionY. This is not ideal.

      We should prevent this auto upgrade.

        Attachments

          Activity

            People

            • Assignee:
              chris Chris Gianelloni
              Reporter:
              sree Sreevatsan Raman
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: