Coopr
  1. Coopr
  2. COOPR-695

Switch from rest_client to rest-client gem

    Details

    • Type: Improvement Improvement
    • Status: Open Open
    • Priority: Minor Minor
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: 0.9.10 Code Name: Mensa
    • Component/s: provisioner
    • Labels:
      None
    • Rank:
      1|hzymx3:

      Description

      Replace the gem, since rest_client is deprecated...

      WARNING: The rest_client gem is deprecated and will be removed from RubyGems. Please use rest-client gem instead.
      

      Affected files:
      Gemfile: gem 'rest_client', '~> 1.7'
      bin/data-uploader.rb:require 'rest_client'
      lib/provisioner/api.rb:require 'rest_client'
      lib/provisioner/provisioner.rb:require 'rest_client'
      lib/provisioner/resourcemanager.rb:require 'rest_client'
      lib/provisioner/rest-helper.rb:require 'rest_client'
      lib/provisioner/worker/pluginmanager.rb:require 'rest_client'
      lib/provisioner/worker.rb:require 'rest_client'

        Activity

        Show
        Derek Wood added a comment - https://github.com/caskdata/coopr-provisioner/pull/225

          People

          • Assignee:
            Derek Wood
            Reporter:
            Chris Gianelloni
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated: