Uploaded image for project: 'Coopr'
  1. Coopr
  2. COOPR-740

CDH install fails when distribution_version >= 5.3 specified

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.9.9, Code Name: Ursa Major
    • Component/s: templates
    • Labels:
      None
    • Rank:
      1|hzyojz:

      Description

      A validation check for java version in the hadoop cookbook throws a nilpointer during any of the coopr INSTALL tasks, partly because java is not available yet in this context. The culprit code is only executed if a cdh_distribution version >=5.3 is given

      Offending line:
      https://github.com/caskdata/coopr-provisioner/blob/release/0.9.9/lib/provisioner/worker/plugins/automators/chef_solo_automator/resources/cookbooks/hadoop/recipes/repo.rb#L145

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                derek Derek Wood
                Reporter:
                derek Derek Wood
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: