Uploaded image for project: 'Coopr'
  1. Coopr
  2. COOPR-823

Update Ruby to 2.x

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Blocker
    • Resolution: Unresolved
    • Affects Version/s: 0.9.9, Code Name: Ursa Major
    • Fix Version/s: 0.9.10 Code Name: Mensa
    • Component/s: plugins, provisioner
    • Labels:
      None
    • Rank:
      1|hzzrs7:

      Description

      The latest versions of Mac OS X ship with Ruby 2.4.0p0, but we're constrained to RubyGems that support Ruby 1.9, currently. This makes Coopr Standalone unusable on these machines. It also makes it impossible to use the ancillary scripts, such as data-uploader.rb on these machines.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                nitin Nitin Motgi
                Reporter:
                chris Chris Gianelloni
              • Votes:
                1 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: