Uploaded image for project: 'CDAP'
  1. CDAP
  2. CDAP-10237

Running an S3 pipeline created using an 1.4 version of core-plugins fails on 4.0

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 4.0.0
    • Fix Version/s: 4.0.0
    • Component/s: Pipeline Plugins, Pipelines
    • Labels:
      None
    • Release Notes:
      Hide
      Any Hydrator pipelines that use S3 (either as an S3 source or an S3 sink) based on core-plugins version 1.4 (used in CDAP prior to 4.0.0) will not execute on a 4.0.x cluster. A workaround is to recreate (clone) the pipeline using a newer version of core-plugins (version 1.5 or higher).
      Show
      Any Hydrator pipelines that use S3 (either as an S3 source or an S3 sink) based on core-plugins version 1.4 (used in CDAP prior to 4.0.0) will not execute on a 4.0.x cluster. A workaround is to recreate (clone) the pipeline using a newer version of core-plugins (version 1.5 or higher).
    • Rank:
      1|hzzqnz:

      Description

      To reproduce:
      1. Deploy an S3 pipeline on 3.5 cluster (using 1.4.x core-plugins).
      2. Upgrade the cluster to a 4.0 cluster.
      3. Run the pipeline w/ either an S3 sink or S3 source. It will not execute successfully.

        Attachments

          Activity

            People

            • Assignee:
              nitin Nitin Motgi
              Reporter:
              ali.anwar Ali Anwar
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: